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The help file contains a list of all Help topics available for NEWTNews.    You can use the scroll bar to see 
the entries that are not currently visible in the Help window.

For information on how to use Help, press F1 or choose Using Help from the Help menu.
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Overview

The NEWTNews application allows you to subscribe to newsgroups on the Usenet, read articles, post 
articles, post follow-up articles, and check for new article groups.

Usenet is a public forum for the exchange of ideas in the form of news articles that are broadcast to 
member sites.    News articles that are posted on the Usenet are classified into newsgroups according to 
their subject matter.    The number of newsgroups available to you will be set by your system 
administrator.    However, the number of available groups is sometimes restricted to limit telephone traffic 
and disk space usage.

Newsgroup Types
Newsgroups are divided into the following seven main categories:

News Group          Description
comp                                groups relating to some aspect of computer science (for example, comp.ai)
sci                                        groups relating to sciences other than computer science (for example, sci.physics 

or sci.math.symbolic)
news                                groups relating to news software in general and the administration of Usenet news 

(for example, news.admin or new.announce)
rec                                      groups relating to recreational activities and hobbies (for example, rec.arts.sf-lovers

or rec.games.chess)
soc                                      groups for social interaction or discussion of social topics (for example, soc.singles 

or soc.culture.jewish)
talk                                      groups prone to extended heated discussion (for example, talk.religion or 

talk.politics)
misc                                  groups that do not fit into any of the other categories (for example, misc.jobs.offered

for job postings)

There are also local newsgroups whose names begin with a distribution prefix that restricts the 
distribution of the newsgroup to certain geographical areas or organizations.    For example, a prefix ca. in
the newsgroup ca.wanted indicates that it will only be distributed to sites in California.

In addition to the standard seven hierarchies, and local or regional groups, there are several alternative 
hierarchies.    These are created by groups of people who agree to carry and distribute these groups, 
independently of the standard hierarchies.    Some of the major hierarchies are:

Hierarchy            Description
alt                                  Short for alternative.    The original alternative hierarchy.    A major feature is that 

anyone may create any group they please.    Major groups include alt.gourmand, 
alt.aquaria, and alt. sources.

gnu                                A set of groups devoted to the Free Software Foundations GNU project.
pubnet                      Groups devoted to the interests of public access UNIX sites.
bionet                        Groups devoted to the exchange of biological information.



New

New creates a new configuration template.    Your settings for a mail session can be saved to a 
configuration file which will be loaded when the Mail application is started. The default file is 
NEWTNEWS.CFG.

When you choose New, NEWTNews lets you start with a blank configuration template(file).

To select a new file:

1. Point to the File menu and click the mouse button.

2. Click the New command.



Open...

Open an existing configuration file.    Your settings for a NEWTNews session can be saved to a 
configuration file which will be loaded when the NEWTNews application is started.    The default file is 
NEWTNEWS.CFG.

When you choose Open, NEWTNews lets you load an existing configuration file.

To Open a configuration file:

1. Point to the File menu and click the mouse button.

2. Click the Open command.

3. Select the drive and directory by double clicking the selected item.

4. Enter or double click the filename of the configuration file.

5. Choose OK.



Save

To save your NEWTNews settings to a configuration file which will be loaded when the NEWTNews 
application is started. The default file is NEWTNEWS.CFG.

1. Point to the File menu and click the mouse button.

2. Click the Save command.



Save As...

Save As enables you to select the file name, directory, and drive to be used for saving configuration 
parameters.

To select a new Filename:

1. Point to the File menu and click the mouse button.

2. Click the Save As... command.

3. Select the drive and directory by double clicking the selected item.

4. Enter the file name into the text box.

5. Choose OK.



Page Setup...

Page Setup enables you to define left, right, top and bottom margins other than the default for your 
message page.    You can specify the margins in inches, in centimeters or in points.

To select a new Page Setup:

1. Point to the File menu and click the mouse button.

2. Click the Page Setup... command.

3. Enter the left, right, top and bottom margins as desired.

4. Choose a margin unit if you want to change the default 

5. Choose OK.



Print ...

Send your message to the printer. Verify (e.g. send a print from Notepad) that your printer is defined by 
Windows and connected before you attempt to print a message.

To print the information to your default printer:

1. Point to the File menu and click the mouse button.

2. Click the Print ...command.



Print    Setup...

Print Setup... allows you to modify the printer configuration.

To modify the printer setup:

1. Select the Print Setup... option from the File menu.

2. Select either the default printer or a specific printer.

3. Select Portrait or Landscape page orientation, paper size, and paper source.

4. Select the Options... button to set graphics mode, halftoning, and print quality.

5. Choose the OK button.
.



Exit

To exit the NEWTNews program:

1. Point to the File menu and click the mouse button.

2. Click the Exit command.

Note: The NEWTNews application remembers your window setting (size and position) as you exit (per 
user). The next time you log into NEWTNews, the window will appear in the same place and same size.



Connect

To access NEWTNews, do the following:

1.      Choose the NEWTNews icon.

2.      Choose the Connect menu to display the Connect dialog box.

3.      Enter the name of the host to which you want to connect in the News Server Name: field and 
choose the OK button.

News servers have access restrictions.    You need to get permission from the system administrator before
using that system as a news server.

Note:  The first time you log into NEWTNews, the server name you enter is stored in the .CFG file. It 
automatically connects at startup.    If you disconnect and then connect while NEWTNews is running, it will
ask you for the name of the server.



Disconnect

To disconnect NEWTNews, do the following:

1.      Choose the NEWTNews icon.

2.      Choose the Disconnect button and click on the OK button.

This will disconnect you from the NEWTNews server. 



Groups

To view a list of subscribed groups or to close your current newsgroups and return to the list of subscribed
newsgroups, press Groups from the Groups menu.    Your display will change to the list of subscribed 
groups.

Listed next to each newsgroup are the number of unread articles and the total number of articles in each 
group.



Articles

A news article consists of a header and body.    The header information includes:    the network address of 
the sender, the newsgroups to which the article belongs, a subject, a Usenet message ID, the date it was 
sent by the author, the date it was received at your site, the name of the organization from which it was 
sent and the number of lines in the body of the text.

To view all articles in a selected group, do the following:

1.      Select the group whose articles you want to list.

Listed next to each newsgroups are the number of unread articles and the total number of articles in this 
group. 

2.      Choose Articles from the Group menu.

The articles will be displayed in the order in which the server have received them.    Both subject and 
sender name are displayed

Note: you can select only one group at a time for viewing its articles.



Subscribe...

To subscribe to a newsgroup, do the following:

1.      Select the List All... option from the Groups menu, or choose the Subscribe toolbar button to display 
the Subscribe - All Groups dialog box.

Note:    Constructing the list of all available newsgroups may take several minutes.

2.      Scroll through and select a newsgroup and then choose the Subscribe toolbar button, or double click
on the group.    You can select several groups at the same time.

You can also type in a partial name in the Group Name field to search for a match.    This can really 
help if you know part of the name as many sites have more than 3000 newsgroups.

You can subscribe to one or more groups. The letter S appears to the left of subscribed selections.    

3.      When you are finished select the Exit option from the File menu to update your subscriptions.    All 
subscribed groups now appear on the NEWTNews screen.

If you want to subscribe to additional groups at a later date, you can select the Check New Groups from 
the Groups menu.    This option lists all new groups available for subscription since the last time you 
checked.

Also, and more commonly, the Subscribe toolbar button in the main window shows you the list of all 
groups again.    NEWTNews automatically checks for new groups whenever you start News.    You can 
change this setting in the Preferences menu.



Unsubscribe...

To unsubscribe to or a delete your subscription to a newsgroup, do the following:

1.      Select the newsgroups to which you want to unsubscribe.

2.      Select the Unsubscribe option from the Groups menu.    The selected newsgroups are deleted.



Catch Up

Catchup marks all messages in a particular newsgroup as read even if you have not read any of them.

To mark all your messages as read, do the following:

1.      select the subscribed newsgroup, then select the Catch Up option under the Groups menu.    
This automatically marks all your messages in this newsgroup as read, and brings you back to 
your Groups menu.

All read articles disappear when you exit the current newsgroup.    To keep read articles from disappearing
from the newsgroup upon exit, you can do any of the following:

Before closing the article, select the Mark Unread option from the Messages menu.    This marks the 
article as unread so it will appear the next time you open the newsgroup.

Before closing the article, select the Set Flag option from the Messages menu. The article is marked as 
read but also has the letter"F" next to it indicating that the flag is set and that the read message will not 
disappear from the newsgroup.    Note that the Set Flag option will not mark an article as "read" if it has 
not already been read.



List All

To list all available    newsgroups for subscription, do the following:

1.      Select the List All... option from the Groups menu, or choose the Subscribe... button to display
the All Newsgroups dialog box.

Note:    Constructing the list of all available newsgroups may take several minutes.



Check New Groups

Check New Groups lists all new groups available for subscription since the last time you checked.

To list all available new groups, do the following:

1.      Select the Check New Groups option from the Groups menu. 



View

View allows you to view an article or a number of articles that you have selected.    To view a selected 
article:

1.      Select the article you want to view.

2.      Select the View option from the Messages menu, or double-click on the seleted article.



Post

To post an article on the Usenet and send an article through email, do the following:

1.      Select the Post option from the Messages menu to display the New Article dialog box.

2.      Enter your address (if necessary), subject matter, and the message.

            Choose the Groups... button to display the Newgroups dialog box, and select the desired 
newsgroups.    

            Choose the Names... button to display the Names dialog box and select the addresses of persons 
to whom you want to send your article.

3.      Choose the Send button from the Message menu to post the article.



Reply

To post a reply to an article you have just read, do the following:

1. Open the article you want to reply to and choose the Followup button.    Another screen appears 
containing the same article.

2. Enter your address, the newsgroups you want to send your reply to, and your reply message.    
Choose the Send button.



Print...

Print sends your article to your default printer.    Verify (for example, print from Notepad) that your printer is
defined by Windows and connected before you attempt to print a message.

To print an article, do the following:

1.      Select or view the article, then choose the Print Message button to display the Print dialog 
box.

2.      Choose the OK button to print the article.



Save...

Save desired messages for future reference.

To save a message do the following

1.      Select or view the article, then choose the Save button to display the Save As dialog box.

2.      Enter the Filename, File Type, Directory, and Drive and choose the OK button.



Mark Read

Marks the selected articles as read, whether you have read them or not. 

To mark your articles as read, do the following:

1.      Select or view the article, then choose the Mark read button.

Note that the title of the article you read now has the letter "R" to the left of it indicating the article has 
been marked as read.

To mark all messages in a particular newsgroup as read even if you have not read any of them use 
Catchup



Mark Unread

Marks selected articles as read.

All read articles disappear when you exit the current newsgroup. To keep read articles from disappearing 
from the newsgroups upon exit, you can do one of the following:

1.      Before closing the article, select the Mark Unread option from the Messages menu.    This 
marks the article as unread so it will appear the next time you open the newsgroup.

2.      Select the Set Flag option from the Message menu. 

3.      From the Setting menu, select the Preferences... option and the Show Previously Read 
Messages option.



Set Flag

Set Flag marks one or more messages so they will not disappear from your newsgroups when you hide 
the read messages.

All read articles disappear when you exit the current 
newsgroup. To keep read articles from disappearing from the newsgroups upon exit, you can do one of 
the following:

1.      Before closing the article, select the Set Flag option from the Messages menu. The article is 
marked as read but also has the letter"F" next to it indicating that the flag is set and that the 
read message will not disappear from the newsgroup.    Note that the Set Flag option will not 
mark an article as "read" if it has not already been read.

2.      Before closing the article, select the Mark Unread option from the Messages menu. 

3.      From the Settings menu, select the Preferences... option and then the Select the Show 
Previously Read Messages option to display all articles in a newsgroup, including those 
previously read.    Note that if you are already in a newsgroup and you change this option, it will 
not change the display.    The next time you look at a newsgroup, it will take effect.



Clear Flag

To remove a flag, select the Clear Flag option from the Messages menu.    

Note:  Flagged messages will not be available permanently.    Ask your system administrator to find out 
how long news is kept on the server.



Newsgroups

To select the newsgroups to which you are posting a message, do the following:

1.      Enter the name of the newsgroup or groups, or select the newsgroup or groups to which you 
want to post the message.

2.      Choose the OK button.

Note:    Only the newsgroups to which you have already subscribed appear Newgroups list.



Set Preferences...

You can set preferences to control which articles you want to read and how they should be displayed. 

Select the Preferences... option to set the following preferences:

Preference                                                                                  Description

Show Previously Read Messages              Displays both read and unread messages.

Show Full Header in the Read 
Window                                                                                              Displays the full header in the message including the 

message ID.

Insert original in reply                                                    Includes the original message when posting a follow up.

Hide Empty News Groups                                      Hides the newsgroup if it contains no unread articles.

Check new groups on start up                          Searches for and displays new groups upon starting the application.

Compose Window Width Changes the width of the window.    Set the maximum width only when 
composing a message.

Check for New Messages Checks for new messages in a specified    interval of hours and minutes.

Check the preferences you want to activate and choose the OK button.



Fonts...

Set the font type, style ( including bold and italic ), size and width of the text of a message.

To select a font:

1.                    From the menu item Settings, select Fonts...

2.                  Select the font, font type and font size you want to use.

3.                  Choose Apply to activate your selections.



Colors...

Set both foreground and background colors for your Main, Read. Compose and Subscribe displays.    A 
palette of 16 colors is available. An area that shows the resulted combination is also displayed.

The Items field displays the options:    Main Window, Read Window, Compose Window, and Subscribe 
Window. .

Each of the above fields has also a built-in default. To set the default colors color for a particular display, 
select it from the Items list. and click Default. Clicking the All Defaults sets all fields to the factory-set 
default colors.

To select colors:

1.                  From the menu item Settings, select Colors...

2.                  Select the window you want to change from the items list.

3.                  Select the desired background and foreground colors and choose on the OK button.



Log...

The Log... option allows you to diagnose client and host transmission problems.    You can use the Log for
debugginhg purposes by saving data that is transferred between the terminal emulation program and the 
NEWTNews host into a file.

To Log data, do the following:

1. Select the Log... option from the Settings menu.

2. Choose the Start button to start logging, or the Stop button to stop logging.

3. Choose the Save button to save the contents of the log window to the *.log file.

4. Choose the Print button to print the contents of the log window.

5. Choose the Copy button to copy the contents of the log window onto the clipboard.

6. Choose the Clear button to clear the log window.

7. Choose the Close button to close the Log... option dialog box.



Display Info...

Display Info... allows you to select what information you want displayed regarding    newgroup articles.      
Selections include:    .

From
Subject
Article number
Date sent
Number of Lines

To select your desired display information:

1. Select the desired checkbox indicating your preferences.

2. Choose the OK button.



Toolbar...

Toolbar allows you to display or hide the application's toolbar.    The    toolbar gives you quick mouse 
access to several NEWTNews tools. 



Smart Buttons

Smart Buttons allows you to display toolbar icons and with their description.



Status Bar

Status Bar allows you to display or hide the application's status bar.    The status bar is displayed at the 
bottom of the window where it shows messages and provides statistics about the current application.



Diagnose Connection

Use the Diagnose Connection option to start Ping and verify that the server is available.



Contents

Using Help

To choose a Help topic:

Mouse                            Point to the underlined topic you want to view and click the mouse button.

                                                When the pointer is over an item you can choose, the pointer changes to 
a hand icon.

Keyboard                    Press Tab to move the highlight to the underlined topic you want to view, and 
then press Enter.

To exit Help:

Mouse                            1    Point to the File menu and click the mouse button.
                                                2    Click the Exit command.

Keyboard                    1    Press Alt.
                                                2    Type the letter F.
                                                3    Type the letter X.



About NewtNews...

Additional information is available through the following publications:

Horton, M.R.; Adams, Standard for interchange of USENET messages. RFC1036, 1987 December.

Kantor, B.; Lapsley, Network News Transfer Protocol. RFC 977, 1986 February; 



Troubleshooting

If you experience difficulties using the NEWTNews application, refer to the following items:

o Verify that the installation and setup verification steps have been successfully completed.

o Make sure you the host name to which you are trying to connect is correctly entered. and that the 
system administrator assigned you access permissions.

o If NEWTNews reports a failure to connect, use the Ping application to verify our connection to the 
remote you want to access.

o Verify that the NEWTNews settings are correct and the timer settings for retrieval of new messages 
from the host are set appropriately.






